We're updating the issue view to help you get more done. 

Wrong 'plugin disabled' message when upgrading plugin via file upload

Description

Prerequisites:

  • two versions of the same plugins, initially not installed

Steps to reproduce:

  • install lower version of the plugin

  • enable the plugin

  • install (via file upload) the newer version of the plugin

Expected:

  • plugin upgraded successfully to the newer version (and enabled)

Was:

  • plugin is upgraded and enabled (plugin system works fine), but there is an incorrect message from UPM: "This plugin was successfully installed. However, it is disabled by default" (see screenshot). The plugin is actually in enabled state, as rest of the UI indicates. The message should not be displayed in case of plugin upgrade.

Environment

JIRA, UPM 1.3.1

Testing Notes

None

Security Policy

None

Status

Assignee

Unassigned

Reporter

Dariusz Kordonski

Labels

QA Dev

None

Needs Doc

None

Team

None

External issue ID

None

External issue ID

None

Peer Reviewer

None

Mgr Approver

None

CC

None

Product

None

Payment Model

None

Plugin Key

None

App Key

None

Most Recent Approval Ticket

None

Fix versions

Affects versions

1.3.1

Priority

Minor