The plugin system fails to load plugins compiled with a java 8 source level

Description

Environment

None

Testing Notes

None

Activity

Show:
Marcos Scriven
October 3, 2014, 6:40 AM
Edited

Interestingly, Fisheye plugin resolves fine with wildcard instructions: https://bitbucket.org/atlassian/jira-fisheye-plugin/src/06e71762f97d072a7399f03dd938894df26a85b7/src/main/resources/atlassian-plugin.xml?at=master#cl-39

The charting plugin doesn't specify any wildcards, and also loads fine

Zephyr also loaded fine without any changes

Robbie Gates
October 6, 2014, 11:43 PM

Regarding <_noee>true</_noee> - is this something we expect amps to do in a subsequent version ? Or do we flip this and somehow ensure that our system provides a suitable capability ?

Marcos Scriven
October 9, 2014, 12:49 AM

Re execution envs, I think we should include them after all. I'll change the tests to accommodate the new dependency on the system bundle:

Mark Lassau
October 29, 2014, 1:31 AM

Presumably the fix version here can be changed to "4.0.0" ?

Marcos Scriven
October 29, 2014, 1:35 AM

Yes - I've gone ahead and changed that.

Fixed

Assignee

Marcos Scriven

Reporter

jhinch

Labels

None

Add-on Type

None

Team

None

CC

None

Risk factor

None

QA Kickoff Status

None

QA Demo Status

None

Components

Fix versions

Affects versions

Priority

Major
Configure