Details

    • Type: Story
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: M5 (1.1)
    • Component/s: None
    • Labels:
      None

      Description

      Bucket for collecting all the problems the eclipse connector has when running on e3.5.

        Gliffy Diagrams

          Activity

          {annotationCollection: [{}], annotations: [{}], collectionInheritableAnnotations: [{}], declaredAnnotations: [{}], description: Annotated value: thomas.ehrnhoefer@tasktop.com; Annotations: [@com.atlassian.velocity.htmlsafe.HtmlSafe()]} Thomas Ehrnhoefer added a comment -

          Wojtek, I am assigning this to you since as far as I know it was decided that the e3.5 consuming will be done by the Polish team.

          On a side note: I am done consuming the new Mylyn 3.2 API, I took a pass through all plug-in's warnings and fixed those I could easily do without interfering too much with this task here.
          After you (or Pawel) is done with the 3.5 work (there is a couple of APIs now deprecated that were not in 3.4) we should maybe schedule another task for going through the warnings again and list out all we can fix (and add annotations for those we can't)....

          {annotationCollection: [{}], annotations: [{}], collectionInheritableAnnotations: [{}], declaredAnnotations: [{}], description: Annotated value: wseliga; Annotations: [@com.atlassian.velocity.htmlsafe.HtmlSafe()]} Wojtek Seliga added a comment -

          Thomas,

          To be 100% what our task is:

          • fixing all the problems described by subtasks of this issue here
          • getting rid of deprecation warnings
          • getting rid of restricted API warnings (only where really necessary we should use @SuppressWarning)
            AFAIK the project currently compiles against Mylyn 3.2.

          Am I right or did I miss anything?

          Cheers,
          Wojtek

          {annotationCollection: [{}], annotations: [{}], collectionInheritableAnnotations: [{}], declaredAnnotations: [{}], description: Annotated value: thomas.ehrnhoefer@tasktop.com; Annotations: [@com.atlassian.velocity.htmlsafe.HtmlSafe()]} Thomas Ehrnhoefer added a comment -

          That sounds right to me
          I think the biggest problem with e3.5 in using the PLE features are the annotations for the diff editor, they did not show up (all the time) when Steffen tried it a couple of weeks ago. However, I just opened a review file here and they showed...so maybe the problem is gone already.

          {annotationCollection: [{}], annotations: [{}], collectionInheritableAnnotations: [{}], declaredAnnotations: [{}], description: Annotated value: wseliga; Annotations: [@com.atlassian.velocity.htmlsafe.HtmlSafe()]} Wojtek Seliga added a comment -

          it may be Linux related issue. The same happens all the time (with e3.4) for me - I often can't see initially annotations in the text editor (not in compare editor). I need to play a little with the editor to actually see annotations. If this is what Steffen saw, that would mean it's just a bug (not related to e3.5). Could you check with him?

          {annotationCollection: [{}], annotations: [{}], collectionInheritableAnnotations: [{}], declaredAnnotations: [{}], description: Annotated value: spingel; Annotations: [@com.atlassian.velocity.htmlsafe.HtmlSafe()]} Steffen Pingel added a comment -

          I am seeing the markers but the tooltip does not appear since the presentation has changed. Instead of stacking markers Eclipse 3.5 shows a popup with all applicable markers and actions for a source line. Let me know if you are not able to reproduce the problem and I'll attach a screenshot to PLE-305.

          {annotationCollection: [{}], annotations: [{}], collectionInheritableAnnotations: [{}], declaredAnnotations: [{}], description: Annotated value: pniewiadomski; Annotations: [@com.atlassian.velocity.htmlsafe.HtmlSafe()]} Pawel Niewiadomski added a comment -

          @Steffen - please attach screenshot to PLE-305 and I'll investigate.

          {annotationCollection: [{}], annotations: [{}], collectionInheritableAnnotations: [{}], declaredAnnotations: [{}], description: Annotated value: thomas.ehrnhoefer@tasktop.com; Annotations: [@com.atlassian.velocity.htmlsafe.HtmlSafe()]} Thomas Ehrnhoefer added a comment -

          I think this one can be closed then. No new issues came up so far, and it is too late to do fixes now anyway. Everything that does not work has to get into a (new) bug report


            People

            • Assignee:
              {annotationCollection: [{}], annotations: [{}], collectionInheritableAnnotations: [{}], declaredAnnotations: [{}], description: Annotated value: wseliga; Annotations: [@com.atlassian.velocity.htmlsafe.HtmlSafe()]} Wojtek Seliga
              Reporter:
              {annotationCollection: [{}], annotations: [{}], collectionInheritableAnnotations: [{}], declaredAnnotations: [{}], description: Annotated value: thomas.ehrnhoefer@tasktop.com; Annotations: [@com.atlassian.velocity.htmlsafe.HtmlSafe()]} Thomas Ehrnhoefer
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Who's Looking?