The health check should verify if the instance is running a vulnerable version based on our public security advisories

Description

This request is to add a feature to the Health Check to check if the version of Confluence is affected by a security breach based on public security advisories.

For example, on March and April 2019, we had 2 security advisories which impacted all versions of Confluence. As soon as they were made public, the health check should add a warning/banner to the admin section of Confluence (any Confluence admin will see it), showing a link to the advisory and warning that they should upgrade Confluence.

This will implement the notifications sent to Main technical Contacts and users subscribed under Tech Alerts

Environment

None

Assignee

Unassigned

Reporter

Artur J

Components

Labels

Add-on Type

Server

Team

None

CC

None

Risk factor

None

Affected Product/s

Confluence

Priority

Major
Configure