atlas-integration-test does not work in 8.0.4

Description

Summary

atlas-create-jira-plugin does not work in 8.0.4

Steps to Reproduce

  1. run

  2. define the project(in this instance I called it test)

Expected Results

Run without errors

Actual Results

Will produce the following output:

with this error

Workaround

This can be fixed by flipping the order of maven-amps-plugin to amps-maven-plugin like below

Then it works. with the following output

Environment

None

Testing Notes

Add notes...

Activity

Show:
Diego Agulló
June 12, 2019, 6:46 AM

Apparently version 8.0.16 of the atlassian-plugin-sdk has been released on the official apt repositories (https://packages.atlassian.com/atlassian-sdk-deb).

Stefan Glase
June 11, 2019, 7:12 AM

It is more than 4 months now and we are still waiting for a fix to one of the key features of atlas-sdk! Please let us implement and create quality proven and tested software with that tool.

Michael Vlasov
June 10, 2019, 8:38 PM

When is it expected to be released? Currently latest released version is 8.0.7, not even 8.0.10 that is mentioned in affected versions. It is a blocker for plugin development! Actual released version of SDK is non-functional.

Benjamin C. John
May 22, 2019, 6:08 AM

Hi Ashwal Dixit,

will this issue be fixed in the new SDK or not? You added fixed version 8.0.10 and affected version 8.0.10.

Thank you in advance.

Cheers,

Benjamin

Vivek Verma
March 28, 2019, 3:34 AM
Edited

Removed cli command and fixed integration-test command and clover command.

Fixed

Assignee

Vivek Verma

Reporter

Ian Gil Ragudo

Labels