We're updating the issue view to help you get more done. 

JDK 1.7 compatibility

Description

Fisheye/Crucible is targeting JDK 1.7 compatibility for our next release. The ActiveObjects plugin is throwing errors on startup:

1 Detected an error (BundleException) enabling the plugin 'com.atlassian.activeobjects.activeobjects-plugin' : Unresolved constraint in bundle com.atlassian.activeobjects.activeobjects-plugin [14]: Unable to resolve 14.0: missing requirement [14.0] package; (&(package=javax.xml.namespace)(version>=0.0.0.1_006_JavaSE)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D

Hacking activeobjects-plugin-0.15.jar/META-INF/maven/com.atlassian.activeobjects/activeobjects-plugin/pom.xml to remove version>=0.0.0.1_006_JavaSE from javax.xml.namespace* and javax.xml.stream* seems to fix the problem, but we need to get it fixed properly.

Environment

None

Testing Notes

None

Status

Assignee

Unassigned

Reporter

Anna Buttfield

Labels

None

Add-on Type

None

Team

None

CC

None

Risk factor

None

QA Kickoff Status

None

QA Demo Status

None

Fix versions

Affects versions

ao-plugin 0.15.2

Priority

Major