Uploaded image for project: 'Atlassian Maven Plugin Suite'
  1. Atlassian Maven Plugin Suite
  2. AMPS-930

Allow excludedGroup to be passed in to surefire when running unit-test

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 4.1.2
    • Fix Version/s: None
    • Component/s: Maven AMPS plugin
    • Labels:
      None

      Description

      It is useful to be able to group/exclude unit tests (via profiles, for example). In amps, func tests can be grouped, but not unit tests, because the UnitTestMojo hardcodes the excludes.

      Make the UnitTestMojo.runUnitTests() take in an excludedGroups parameter, and add that to the configuration passed to surefire.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              mscriven Marcos Scriven added a comment -

              As there are currently over 300 issues open in AMPS that date back to 2009, we need a way to attack such a large mountain.

              The first phase of this is to throw back 246 of these issues that were created before May 2013 (i.e. over a year ago) by users with atlassian.com email addresses (the only way we could establish as 'internal')

              This comment has been added in bulk to all those 246 JIRAs, which will also be marked as 'closed'. If you think the issue is still relevant, please report it as a new issue on the new AMPSDEV project: https://ecosystem.atlassian.net/browse/AMPSDEV or if it's truly a public issue, just reopen it.


                People

                • Assignee:
                  Unassigned
                  Reporter:
                  jxie Joe Xie
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Who's Looking?