Upgrade Tomcat version to 8.0.48 or higher

Description

Summary

Latest versions of Confluence run on Tomcat 8.0.48 while AMPS only let us run apps on Tomcat 8.0.36.

This might be the reason when we run Confluence 6.x (specially since 6.4) using atlas-run, atlas-debug or atlas-run-standalone the performance is way worse than when we run a normal standalone instance even when using the embedded H2 database. In any case, I think it should be upgraded in next Atlassian SDK.

Notes

The Apache Tomcat guys recommend using Tomcat 8.5.x instead of 8.0.x especially since 8.0.x EOL is approaching: 30th of June 2018 https://tomcat.apache.org/tomcat-80-eol.html

Environment

None

Testing Notes

None

Assignee

Mel Paisley

Reporter

Angel Ruiz

Labels

Add-on Type

None

Team

None

CC

None

Risk factor

None

QA Kickoff Status

None

QA Demo Status

None

Story point estimate

None

Sprint

None

Fix versions

Priority

Major
Configure