Make AMPS compatible with Java 11

Description

AMPS currently does not compile when using Java 11. In addition, some of the maven-amps-plugin tasks do not work under Java 11 because they rely on maven plugins that are too old.

Tasks:

  • upgrade commons-lang to commons-lang3 3.8

  • upgrade guava to 26.0-jre

  • upgrade mockito to 2.21+

  • upgrade a number of maven plugins (enforcer, surefire, bundle, javadoc)

Environment

None

Testing Notes

Add notes...

Done

Assignee

Bryan Turner

Reporter

Michael Heemskerk

Labels