Default to Closure Compiler for JS minification

Description

Given that YUI Compressor is EOL, chokes on compressing a lot of modern Javascript libraries (examples: Angular / PDF.js). Is there any reason why we shouldn't opt in to using Closure by default in all newer versions of AMPS?

Environment

None

Testing Notes

None

Activity

Show:
Marcos Scriven
September 30, 2015, 9:38 AM

Unfortunately we have a large backlog of issues in AMPS, and are now trying to prioritise them. We have thus closed this issue with the resolution Timed Out because:

  • It has had no activity in the past six months.

  • Has no more than one watcher or voter.

If you feel this issue is still relevant, then please feel free to reopen it. You can do this my clicking the Reopen Issue button at the top of the issue view.

If you do decide to reopen it, then you can really help us out by:

  • Trying version 5.0.25 of AMPS or stating why you can't upgrade. (Note if you're moving from 4.x you'll need to be on Maven 3.1 or above)

  • Checking the issue still occurs, attaching recent logs.

  • Making sure the title of the issue is as descriptive as possible.

  • Ensuring full and clear steps to reproduce are in the description.

  • Adding a comment with any current updates or further info.

We apologise we've not been able to look at your issue directly.

Fixed

Assignee

Chris "Daz" Darroch

Reporter

Samuel Day